Link to Top

Skip to main content
Alert Message Icon

Please upgrade your browser.

Your browser is out of date. For a faster and more secure online experience upgrade your browser to the most recent version. Click here for a list of recommended browsers

Begin Site Message Content
+
Alert Message Icon
End Site Message Content

Action Needed to Fight Fraud.

Update Credit Card Terminals

Many clients have already updated and no further action is needed but we want to make sure everyone is ready.

What's happening?

  • There is a new internet security standard called SHA-2 (the Secure Hash Algorithm technology)
  • Your point-of-sale (POS) terminal must be upgraded to work with this new security standard
  • Improves how your customers' payment information is encrypted

Why do I have to upgrade?

  • Point of Sale Solutions not compatible with the new standard won't be able to process payments unless there is a dial-up connection

What do I need to do?

  • Contact your relationship manager
  • Contact Merchant Services:
    • For point-of-sale (POS) terminals, please contact 1-888-354-3055.
    • For Net Connect and Orbital Integrators, please Click Here or contact 1-800-254-9556.

IMPORTANT. TAKE ACTION NOW.

If your terminal is not compatible with the new SHA-2 security standard, you won't be able to process payments unless you have a dial-up connection.

Fraud may never be completely stopped. But to drive it away from your business, the time to act is now. Your customers, and your bottom line, will be the better for it.